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Stop (de)bugging me!
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Who am I

» Freelance consultant/ developer

From the Netherlands

» IBM Notes/ Domino
XPages, web, client, mobile (TeamStudio Unplugged)

» OpenNTF Contributor

XPage Debug Toolbar ‘4
Auto Logins for Domino IBMCHAMPION A,

XPage Multiple File Uploader
» IBM Champion for 2 years in a row



Agenda

» Debuggers in Designer

Java debugger

SSJS debugger

» XPage Debug Toolbar ™
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Debuggers in Designer

» For Java & SSJS (starting with 9)
» Based on standards

Java Platform Debugger Architecture (JPDA)
» ‘Remote’ debugging

Enable on server

Client (Designer/ Eclipse) connects to Server on specified port

Only | developer at a time can connect

» Not recommended for productions servers

Impacts performance and security m
But that’s not a problem

Since we all never debug applications on production servers
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Java debugger

» In Designer since 8.5

» Debug:
Java classes
Managed beans

OSGi plugins
Compiled XPages Java (Local/xsp folder)



Server Side JavaScript debugger

» New in Domino 9

» Configured and works (almost) the same as the Java
debugger

» Debug SSJS in the XPage source or a S§JS library

Set breakpoints

Right-click in gutter
debug55J5 - XPage

<?xml version="1.8" er
<xpiview xmlns:xp="ht

Add ‘debugger’ statement

Don’t use this in Designer pre-9 versions!

<xp:this.beforePa;
<! [CDATA[#{ja

I @ N R

(=1 . PEPET e )

Teggle Breakpoints
Enable Breakpoints
Breakpoint Properties..,

Run As




Activating the debuggers - server

» Add configuration to notes.ini:

JavaEnableDebug=| Add thisd"‘LW OS“';J)’Sif()’OU) want to
ebug too
JavascriptEnableDebug=|1

JavaDebugOptions=transport=dt_socket,server=y,suspend=n,address=8000

» Tip:if you click on the “Debug” icon in the toolbar, you
can copy-paste these settings from there
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Activating the debuggers - server

» Restart the server
» Woatch for this:

A3-18-2013 A?:23:55 PM JUM: WARMING: HRemote Java Debugging is enahled, resulting in decre

azed performance and potentially compromized securit

» Port needs to be open(ed) in the firewall
» Works with local HTTP preview too

Add settings to local notes.ini

» If the local preview won'’t start, try starting the local
HTTP task from a command prompt

Run “nhttp preview” from your Notes folder
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Starting a debug session

» Click the triangle next to the “bug” icon

B A el I e

| 23 Mew Configuration
Manage Debug Configurations...

(this is Designer 9, icon looks slightly different in 8.5)

» Select an existing configuration or click “Manage...”
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Starting a debug session - Java

IS

#i Debug Configurations

Create, manage. and run confiqurations

Attach to a Java virtual machine accepting debug connections

S_q

o -+
CEX| B3~

Mame: Debuglava

<—— | Name for this configuration (can be any)

4 05Gi Framework
E Remote Java Application

Debuglava \

Host:  localhost

Port: 8000

[] Allow terminatic

type filter text =
L Cunnectl B 50urce| =] Common|
£J Demino Designer JavaScript )
& Eclipse Application Project
& HTTP Preview stop.nsf
Ju JUnit :
F% JUnit Plug-in Test EATEE o T
Java Applet | Standard (Socket Attach)
Java Application

Connection Properties:

G

IP Address of your server

f rermote Wi

Port that the Debugger listens on

Revert

Filter matched 11 of 11 items




Starting a debug session - SSJS

S 2 -
\ b & X | H & Mame: Debugss)s

&JE filter text
b Cannect]

24 Domine Designer JavaScript

Domine Designer Server Connection Properties

£J Debug5sls
£ Eclipse Application To debug server-side JavaScript, the server must be set up to start in debug mode.
B HTTP Preview = Server setup details
Ju JUnit To start the server in debug mode, add the following variables to the server's NOTES.IMI, then restart t
g ijt:Iulg;n Test JavaknableDebug=1
ava App

= JavascriptEnableDebug=1
] Java Application JavaDebugOptions=transport=di_socket, server=y,suspend=n,address=8000
& 05Gi Framework

E Remote Java Application . . - .
E Debuglava Depending on your environment, you may want to turn off debug mode after you finish debugging.

The value for "address” must be the port number specified in this configuration,

Host: 192168.137.9

Port: 8000

Debugging behavior
Stop at first line of server-side JavaScript in:

@ All JavaScript

() Design elements only

Apply I ’ Revert
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Debug perspective

» Designer automatically asks to open Debug perspective
when it suspends

Breakpoint or ‘debugger’ statement in SS)S

#i Confirm Perspective Switch &

% This kind of launch is configured to open the Debug perspective when it suspends,

~ This Debug perspective is designed to support application debugging. It
incorporates views for displaying the debug stack, variables and breakpoint
management.

Do you want to open this perspective now?

[ Rermnernber my decision

» Change behaviour in Preferences > Run/Debug > Perspectives
» Tip: switch perspectives using Ctrl-F8 in Designer
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» Demo



Source not found?

@4 Edit Source Lockup Path u

p¥ Thread [Thread-5] (Running) Edit the path used to locate source files. -
g2 Thread [Thread-6] (Running)

4 i Thread [Thread-7] (Suspended)
14| 1 |

[ debugJava - XPage = " [J] JavaDebugDemo.j

Source Lockup Path:

Source not found, > = Default| Add...
’Edit Source Lookup Path... ] ) Edit...
. & Add Source u Up

Select the type of source to add 53/ Project Selection = | B |
_— ey,

Source folders in a Java Project =
Choose project(s) tcm

= .

() Archive Tl stop.nsf

{7} External Archive [] @i# openLog.nsf
[=File System Directory
@ Java Claszpath Variable

B Java Library

E-Java Project | > i i
(= Workspace Folder Add exported entries of selected projects,
i Add required projects of selected projects.
oK | ’ Cancel ] oK | [ ol l BLUG
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Keyboard shortcuts

» F5
» F6
» F7
» F8

Step into
Step over
Step exit

Continue

| %% Debug x || Wik Servers |

% 0w Hla. e s |29
Y @ Thread {F7 )
= JavaDebugDemo.getResult() line: 17
= hlativebdethnrd Arreconr Trnl inwnl-=NikA=thnd

» Strange issue with the Fé key

With the default Designer/ Eclipse binding it doesn’t work

If you create your own binding to F6 it does

Do this in File > Preferences > Type “keys” in filter



Conditional breakpoints

» Set breakpoint
» Right-click on breakpoint
» Click “Breakpoint properties”

-

&5 Properties for

type filter text Server Side JavaScript Breakpoint <7
Seessiley ayshenpt sk Type: ssjsxsp/ xpaview[1]xp [Line: 11]
Enabled
Enable Condition
i==3
4 1 [ b
[ OK J ’ Cancel




Display view

» Window > Show Eclipse View > Display

» Run an expression in the context of a breakpoint and
view the result

» Only works with Java debugger, not SSJS debugger
» Has code completion

| El Console (No consoles to display at t... " ¥ Tasks " 4] Display x

context
(com.ibm.xsp.designer.context.ServlietXSPContext) com.ibm.xsp.designer.context.ServlietXSPContext@S8535853
foo
Evaluatieon failed. Reascni(s):
foo cannct be resolved
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Expressions view

» Window > Show Eclipse View > Expressions
» Inspect the current state of objects
» 2 ways to add:

Right-click on expression in ‘Display’ view
Type in manually

= Variables || % Breakpoints " 61" Expressions X

£ BB % %

2 "context"= ServietXSPContext (id=1107)
E _context= DominoFacesContext (id=1634)
B _requestUrl= null
m _sessionData= PersistentSeszsionData (id=1802)
B _userfgent= null
B preventRecurse= false

%Y "foo"= "bar” (id=1818)
g count= 3
B hashCode= 97299
E hashCode32=10
o offset=0
g value= char[3] (id=1826)




From SSJS to Java

» You can debug Java code when you're debugging SS)S
code

» But NOT using “Step into” (F5)

It will only stop on breakpoints in the Java class

S BLUG



Disconnect

» When you’re done: disconnect your debugging session

Java debugger

[ ﬁ%[]ebug I\ Servers |
il E4
i ead [Phread-9] (Running)

& Thread [Thread-10] (Running)
p® Thread [Thread-11] (Running)

SSJS debugger

lf‘i[ﬁlebu : til Servers |
| Bk

4 ) Debdg55)s [Déminc Designer JavaScript]
4 Connected to 8000:192.168.137.9
g2 Thread [main] (Running)
& Daemon Thread [Attach APTwait loop] (Running)
p¥ Daemon Thread [MotesGCThread0] (Running)
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XPage Debug Toolbar

- C [ noralinged.local/blug/stop.nsf/debugToolbarxsp

il XPage Debug Toolbarvd %

ﬂ applicationScope sesszionScope viewScope reqguesiScope files environment & Java inspector about remove

refresh | add divider | clear mes=sages | show miliseconds | open in external window

12:40:17  com.ibm.jscript.InterpretException: Script interpreter error, line=4, col=30: "doc’ is null
zhow =tackirace

12:40:17  an error occurred

12:40:17 arning mess pm A butto

12:40:16  info mes=sage using S3JS from a button

12:40:16 debug message using S5J8 from a button

12:40:15  (=etDemoScopeVariables) Done adding

12:40:15  (timer stopped) adding scope Messages
12:40:15  (timer starfed) adding scope messages
12:40:18  (=2etDemoScopeVariables) Adding demo values to the various scopes...

developed by Mark Leusink
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Background/ features

» Tool for XPage developers —

» Free download from OpenNTF ﬂl]ﬂl]“TFl:pl'g

Or directly from GitHub

» Features:

Log debug messages

Using print() or _dump() for debug/ log messages is NOT very
convenient

You need access to server console
Messages from everyone (and server messages) in one stream
Makes administrators unhappy

View contents of scopes
Log file reader
API Inspector
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Components

ccDebugToolbar

xpDebugToolbar
eu.linged.debugtoolbar.DebugToolbar
eu.linged.debugtoolbar.Message
debugToolbarConsole
debugToolbarErrorPage

dBar

Events

Event

Custom control
SSJS library
Java class

Java class
XPage

XPage

Managed bean

View

Form

optional

optional

Openlog
integration

Openlog
integration



Installation

» 2 ways to install:
Download from OpenNTF and copy to your application
Use the OpenNTF Import/ export tool

(&

Import Reusable Control

Import Reusable Control from QpenMTF into an existing Dominc Application.

Select Reusable Controls:

4 [ Apache Catalog
[ ccTweetQuote
[ Google Maps Custom Contral
[] mimelDominoDocument Data Source
[] Recaptcha Custarn Contral
[] View Picklist Custorm Control
[ %Grid
[] ’dnvolve Custom Control
#Page Debug Toolbar
[] ¥Page Standby Dialog Custom Control

[— T




Installation

» Add the (dBar) managed bean

» Add the ccDebugToolbar custom control to your
XPage

» Change the default settings using custom control
properties

collapseTo
defaultCollapsed _

debugToolbar - XPage =B X
color

XPage Debuqg Toolbar v3 (by Mark Leusink)




Scope contents

» Shows contents of application-, session-, view- and
requestScope

» Remove a variable

Or clean an entire scope

» You can modify values through the Inspector

) BLUG



Environment variables

» Information about the current:

User
Browser
Server
Database
Request
» Java heap size Java memory usage
Maximum heap size maxinumnesp size 840 1)
used =0
Allocated e
Used Run garbage collector
Free

=) BLUG



Inspector

» View classes for controls on the current page
And change them

» View any variable:

Scoped variables
Click on the (i) to open a variable in the Inspector

Managed beans _ m
Shows all properties and methods "ﬂmnkﬂp‘"

An), Xpage runtime object° clear application- ang gessionScope
b
database cem e
. CCESS com.ibm
session ——
context
view

» Drill-down to see what value/ object is returned
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Messages

» Add message logging calls to your application
» Developer / session specific messages

Cleared when browser is closed

» Add messages using:
dBar.debug( “message” )
dBar.info( “message”)
dBar.warn(“message” )
dBar.error(“message” )
dBar.dump( <object>)

» Specify a context using an optional 2" parameter:

Y ¢

dBar.info( “message”,“context’ )
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Messages

» dBar.error() function accepts ‘error’ objects:

try {
var doc = null;

var id = doc.getUniversallD();
} catch (e) {
dBar.error(e);

}

» Add a divider: dBar.addDivider();
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Messages

» Messages can also be written from Java

DebugToolbar.get().info( “message” );
DebugToolbar.get().warn( “message” );

» Or catch an Exception

DebugToolbar.get().error( e );



Log messages to documents

» Create documents for all dBar calls

In a configured database
» All required code already built-in

» Uses the OpenLog (form/fields) format
Use the Openlog database to view them

» Log level can be set: log only messages with a certain log
level (or ‘higher’)
warn = warn + error

debug = debug + info + warn + error
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Log messages to documents

» Configure using managed properties

logDbPath current, logdb.nsf
logEnabled true, false
logLevel debug, info, warn, error

» Logging will continue even if the toolbar isn’t displayed !
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Best practices

» Add [debug] role to the ACL

» Set loaded property of the ccDebugloolbar only for
[debug] role:

loaded="#{javascript:context.getUser().getRoles().contains(‘[de
bug’]}”
» Enable logging to documents

logLevel =“warn” (errors and warnings only)

» Leave everything in when moving to production
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Resources

» XPage Debug Toolbar on OpenNTF

http://www.openntf.org/internal/home.nsf/project.xsp?action=op
enDocument&name=XPage?%20Debug?%20Toolbar

» XPage Debug Toolbar on GitHub
https://github.com/markleusink/XpageDebugToolbar

» OpenNTF Import/ export tool

http://www.openntf.org/internal/home.nsf/project.xspfaction=op
enDocument&name=Import%20and%20Export%20for7%20Design
er

» OpenLog

http://www.openntf.org/internal/home.nsf/project.xsp?action=op
enDocument&name=0Openlog



http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=XPage Debug Toolbar
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=XPage Debug Toolbar
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=XPage Debug Toolbar
https://github.com/markleusink/XpageDebugToolbar
https://github.com/markleusink/XpageDebugToolbar
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=Import and Export for Designer
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=Import and Export for Designer
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=Import and Export for Designer
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=Import and Export for Designer
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=OpenLog
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=OpenLog
http://www.openntf.org/internal/home.nsf/project.xsp?action=openDocument&name=OpenLog

Thank you !

» Twitter: markleusink
» Skype: mark_leusink
» Blog: http://linged.eu

» Email: m.leusink@linged.eu



http://linqed.eu/

